Integrate Everything

Collets, Christmas and Catastrophes!

A few weeks ago I ordered a three-pack of different-sized collets for the router in the Shapeoko, and yesterday they arrived. One of the things I love about shopping online is that with the delay in shipping sometimes, you can easily forget that you’ve even ordered anything and such was the case this time. When I opened the mail and found this cardboard box addressed to me, I had no idea what might be inside, and was just as pleasantly surprised when I opened it and realized it was something I’d wanted for a long time!

As it turned out, I had been discussing at that *very* moment a Christmas project my wife wanted to do with some letters cut out of wood, much like I had done on the Shapeoko in previous years. With the new collets in hand, I was more excited than ever to give them a try! Yesterday morning I headed out to the garage early in the day to begin dusting off the Shapeoko. It had sat in it’s corner for several months prior to this, having cut all that I needed it to. I had been experimenting with using Inkscape to generate items with pockets – carving out sections of wood with the end mill, and was getting quite good at it. The only problem I kept running into was that the bit would sometimes slip, drop, and then gouge the wood it was trying to cut a pocket in. Hence my delightment at getting the proper collets for the router.

I spent the better part of Saturday working on this, and cutting out letters for my wife’s Christmas craft. They turned out practically perfect, and I was thrilled with the results. I repositioned the wood I’d been cutting from to make one last set, and was positioning the router into place when all of a sudden Carbide Motion reported that it couldn’t talk to the Shapeoko. That’s odd, I thought, but sometimes it would disconnect when the router was switched off, so I wondered if maybe this wasn’t a similar problem. I unplugged the USB cable and plugged it back in. No dice. Power-cycled everything. No dice. Even rebooted my computer. Nothing. It was as if the USB cable wasn’t even plugged in. I checked dmesg – and there was no indication as far as the computer was concerned that anything was plugged into the USB port. It was dead in the water.

And so it sits now. We’ve contacted Carbide to see if they sell the controller separately. I can read and write the Atmega 16U2 chip which is the USB to TTL converter for the driver board, so it seems to be OK, meaning the problem is most likely elsewhere on the board in some other tiny component. When powered from the 24VDC power supply, the 16U2 has power, so that’s not the problem, and there are only four components between the 16U2 and the USB port which all seem to check out, so I am truly at a loss for what might be causing it to not appear on the bus. Wiggling the board doesn’t help, and like I said – it was working fine all day and then suddenly just disconnected. Bizarre. Maybe it is time to consider a controller upgrade as well.

 

Leave a comment for: "Collets, Christmas and Catastrophes!"

You must be logged in to post a comment.